944/2 944/2
Discussions on the Porsche 944/2
(Moderators: XxSteve944onlinexX, IAN - 944ONLINE)
Topics: 4878
Posts: 36118
Pages Pages: [1] 2 3 ... 244
 
Subject / Started By Replies Views Last Post
 Important Topics
Silicone Vacuum Hose - updated with diagram

Started Jan 22nd, 2010 at 9:01pm by JAMIE944
10 8230 Last Post Mar 30th, 2012 at 12:07pm
By: unL33T
LINK TO TECH SECTION

Started Oct 17th, 2012 at 3:50pm by IAN - 944ONLINE
0 12596 Last Post Oct 17th, 2012 at 2:50pm
By: IAN - 944ONLINE
 Board Topics
AC works, but then blows hot air

Started Sep 25th, 2020 at 1:44am by cwerner@temple.edu
0 81 Last Post Sep 25th, 2020 at 1:44am
By: cwerner@temple.edu
Strange no spark condition

Started Sep 29th, 2019 at 4:14am by sc_mb_944
5 2287 Last Post Sep 10th, 2020 at 2:56am
By: sc_mb_944
lower balance shaft seal area leak - expert input

Started Sep 1st, 2020 at 9:33pm by 9444fun
6 272 Last Post Sep 4th, 2020 at 7:02pm
By: XxSteve944onlinexX
coolant gauge reading

Started Aug 23rd, 2020 at 11:04am by jvc
3 284 Last Post Aug 31st, 2020 at 12:10am
By: jvc
Maintenance required

Started Aug 8th, 2020 at 8:31pm by Mark-GAC
6 426 Last Post Aug 29th, 2020 at 3:00pm
By: Mark-GAC
 10
unreliable starting problem HELP

Started Jul 10th, 2020 at 12:04am by Rayce
13 856 Last Post Aug 25th, 2020 at 1:53am
By: Rayce
KLR Box

Started Aug 20th, 2020 at 12:38am by Mark-GAC
2 213 Last Post Aug 20th, 2020 at 10:15pm
By: Mark-GAC
1988 Automatic damper to clutch conversion

Started Jul 28th, 2013 at 4:25pm by bkhitech
4 927 Last Post Aug 20th, 2020 at 1:57am
By: capt
AC blower motor slows when accelerating

Started Jul 18th, 2020 at 11:19pm by jb944
2 415 Last Post Aug 10th, 2020 at 6:31pm
By: Dave W
NA MAF Kit

Started Jul 2nd, 2020 at 3:09am by Ian_B
4 721 Last Post Jul 31st, 2020 at 6:57pm
By: Chabaz1
Overheating Resevoir Draining from Overflow tube

Started Jul 15th, 2020 at 6:36pm by Carbon1
2 363 Last Post Jul 15th, 2020 at 7:23pm
By: OhioTom
944/NA '86 - Engine starts and then dies

Started Jun 26th, 2020 at 9:24pm by camhedge
2 633 Last Post Jul 1st, 2020 at 9:57pm
By: Dave W
 25
Think my Head Gasket Failed

Started Aug 16th, 2018 at 4:57pm by jacob estes
« Pages 1 2 3 »
This topic contains 2 attachments
30 5311 Last Post Jun 30th, 2020 at 9:12pm
By: jacob estes
Instaling Transmission: Coupler dosn't line up

Started Jul 24th, 2011 at 10:53pm by shibby_cbs
8 1766 Last Post Jun 9th, 2020 at 3:13pm
By: L-Train8
1986 battery drain.

Started Jun 5th, 2020 at 8:21am by Retrojoe
2 751 Last Post Jun 5th, 2020 at 9:52pm
By: Retrojoe
 10
'86 NA overheat adventure

Started May 19th, 2020 at 3:14am by n727gs
11 1459 Last Post Jun 5th, 2020 at 1:44pm
By: OhioTom
No trip, tach and speedo starts at 50kmh

Started May 21st, 2020 at 12:23pm by TheBorgli
6 1123 Last Post May 25th, 2020 at 10:50am
By: anchor
"emissions tube" broken

Started Mar 28th, 2020 at 9:49pm by jbob42
2 1330 Last Post May 21st, 2020 at 8:04pm
By: Dave W
Pages Pages: [1] 2 3 ... 244
 
Normal Topic
Sticky Topic
Locked Topic
Sticky Locked Topic
Moved Topic
Global Announcement
Locked Global Announcement
 10 Hot Topic (More than 10 Replies)
 25 Very Hot Topic (More than 25 Replies)
You can view Topics in this Board.

You cannot post replies to Topics in this Board.
You cannot start new Topics in this Board.
You cannot post Attachments in this Board.
You cannot start Polls in this Board.
 
  ‹ Board Index    ^Top