Page Index Toggle Pages: 1 Send TopicPrint
rust problem? (Read 3230 times)
944S290
New Member
*
Offline


I love Forum 1G - SP1!

Posts: 1
Joined: Feb 27th, 2007
rust problem?
Feb 27th, 2007 at 6:35pm
Print Post  
1990 944 S2
45K mi

Long time lurker. I've never posted because I've always found what I needed by searching, but I can't find an answer to a question.
My dad bought the S2 new in '90. As the miles show, it wasn't driven a lot. He recently purchased a '07 Cayman as his new toy and I was very, very lucky to recieve the S2. It is mint and still has that distinct Porsche/leather smell. The car has always been garaged, is in Texas and had never seen snow/road salt. Until.... In December he took it on it's longest road trip ever to Colorado. It was driven in dry dust/road salt, minimal wet stuff. It all seemed to  have rinsed off and when I got the car three weeks ago I pressure washed the undercarriage.
Did this one salt bath set up future problems with rust? Can I do anything else? Being from Texas I have little experience with rust and cars. I plan on keeping it for a long time and want to prevent rust.
  
Back to top
 
IP Logged
 
IAN - 944ONLINE
Global Moderator
*****
Offline



Posts: 9370
Joined: Apr 26th, 2005
Gender: Male
Re: rust problem?
Reply #1 - Mar 13th, 2007 at 9:53pm
Print Post  
you should be ok - if you washed it well -
I did see a late  944 just eaten away with rust -
and guess where the car was from ?
Yep
DAYTONA !!
You could almost see through the car -
I guess the PO drove it on the beach a lot !!

  

e mail&&ian@944online.com&&phone&&toll free in the USA 1 866 944 7883&&outside the USA&&1 954 968 3766&&FAX -1 954 968 3798
Back to top
WWWYIM  
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo
 
  « Board Index ‹ Board  ^Top