Page Index Toggle Pages: 1 Send TopicPrint
S2 wont turn over after clutch master and slave ch (Read 147 times)
onedirtdog
New Member
*
Offline


944

Posts: 2
Joined: Nov 14th, 2017
S2 wont turn over after clutch master and slave ch
Jul 18th, 2019 at 8:38pm
Print Post  
Hi Everyone, I've had this car for almost 2 years and just getting around to working on it. I changed timing and balance belts water pump, cap and rotor and after sitting that long it fired right up. The next week I changed the master and slave cylinder and now the car wont even turn over, lights on dash and headlights are bright. There is no voltage to the starter from the ignition switch to engage the solenoid. Both ignition relays are good, I do hear a relay or something clicking under the dash when I turn the switch but its not in the relay box under the hood. Is the clutch safety switch just an on off switch because it carries continuity all the time, open or closed. I tried unplugging it but no help. Any help would be appreciated.
  
Back to top
 
IP Logged
 
onedirtdog
New Member
*
Offline


944

Posts: 2
Joined: Nov 14th, 2017
Re: S2 wont turn over after clutch master and slave ch
Reply #1 - Jul 18th, 2019 at 10:15pm
Print Post  
After finding a link to Clarks garage I did a test of the ignition switch, it was fine. I did a continuity check of the red and black wire to the starter solenoid and found it to be open. Upon further exploration I found the red and black connector above the clutch master cylinder and the wire was pulled back enough so it didnt make contact with the other side, Im sure I did this when I replaced the master cylinder. I pushed it back in and the car fired right up.
  
Back to top
 
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo
 
  « Board Index ‹ Board  ^Top