Page Index Toggle Pages: 1 Send TopicPrint
engine stops running after starter disengages (Read 964 times)
Smurf
New Member
*
Offline


944

Posts: 3
Joined: Jul 22nd, 2019
engine stops running after starter disengages
Sep 4th, 2019 at 2:38pm
Print Post  
I have a no run problem with my early 1985 944.  It was my daily driver for 5 years and suddenly it stopped running.  It started a couple of times but quit running and had to be towed home.  I have replaced the following: Ignition switch, battery, DME fuel pump relay, Fuel injection DME temp sensor, both reference and speed sensors, auxiliary/idle control valve, ac electric air valve, all vacuum lines, air flow meter, throttle position switch, throttle body O-ring, DME control computer, engine/fuel injector wiring harness, Fuel pump, fuel filter, fuel filter to pump hard line, in tank fuel screen, fuel injectors, ignition wire set, distributor cap, distributor rotor, ignition coil and spark plugs.  It will start running immediately with starter engagement but will quit running as soon as the key is released to the on position.  If I hold the key to the start position and keep starter engaged, it will continue to run.  I have put a jumper on the DME fuel relay and it does the same thing. I am out of ideas, hopefully someone can help me solve this problem.  Thanks
Smurf
  
Back to top
 
IP Logged
 
anchor
Experienced Member
*****
Offline


*Be vewwy vewwy quiet;
I'm hunting wabbits*

Posts: 935
Location: NOLA
Joined: Jul 22nd, 2015
Re: engine stops running after starter disengages
Reply #1 - Sep 4th, 2019 at 4:22pm
Print Post  
Interesting, try to find a troubleshoot guide as pertains to the check valve at the FP.

The prime DME relay from Focus 9 tech claims to keep it, the FP running in the start position for 3 seconds.

Presently you have tach bounce, right?

One other option is the damper fuel valve test with crimping the hose per Clark's Garage instruct.I'll see if it is in my file manager directory then attach later.

Edit: here is the troubleshooter I referenced to find earlier. Fuel 16, pressure to low or delivery rate not satisfactory.
Fuse 2 at auxillary fuse board might be on the leading edge of your problems or just a loose electrical  connection or the fuel strainer.
« Last Edit: Sep 5th, 2019 at 2:51am by anchor »  

fuel-19.pdf ( 368 KB | 14 Downloads )
fuel-16__2_.pdf ( 105 KB | 12 Downloads )

* Elmuh Fudd / Yosemite Sam... Duuude, I cawwed shotgun dipwomacy 3 minutes ago *
Back to top
 
IP Logged
 
Dave W
Experienced Member
*****
Offline


Just your basic car guy.

Posts: 5722
Location: CA
Joined: Jan 14th, 2009
Gender: Male
Re: engine stops running after starter disengages
Reply #2 - Sep 4th, 2019 at 4:35pm
Print Post  
It is a problem with the DME relay or the wires from it to the fuel pump.  The starter circuit will bypass the DME relay and turn on the fuel pump directly.  This is why it runs with the starter engaged.  Since it runs with the starter engaged, we can assume the fuel pump is ok.   After that, the DME relay powers the fuel pump.  If the relay jumper is in place and you do not hear the fuel pump running regardless of the ignition key position, then something is wrong with the wiring.  Next the DME needs to detect 200 RPM or more from the speed sensor.  If it does not, then it turns off the fuel pump via the DME relay.  You should check the signal wire from the DME to the relay.  You might also check the gap on the sensor.  If too wide, then no signal or weak signal will prevent running.

I should ask: "Have you cleaned all of your grounds?"  The corroded grounds thing causes many unusual problems.
  

Dave - black 84 no longer exists. Sad 83 self destructed. All better now. Smiley
... Let's go hit some twisty roads! ...
Back to top
 
IP Logged
 
Smurf
New Member
*
Offline


944

Posts: 3
Joined: Jul 22nd, 2019
Re: engine stops running after starter disengages
Reply #3 - Sep 5th, 2019 at 10:26am
Print Post  
Thanks for the posts.  I have a constant 40 psi of fuel pressure at the end of the fuel rail.  When I install the DME jumper wire, the fuel pump runs and the condition remains the same.  Car will start but immediately stop running when key is released.  I will insure all grounds are cleaned.  Thanks again.
  
Back to top
 
IP Logged
 
XxSteve944onlinexX
944online Admin
*****
Offline


Don't shoot the messenger.

Posts: 10388
Joined: Apr 6th, 2003
Gender: Male
Re: engine stops running after starter disengages
Reply #4 - Sep 5th, 2019 at 5:33pm
Print Post  
Sounds like you have a bad ignition switch and or key tumbler.
  

Steven Manfre Sales Manager 1501 nw 22nd ct  #10 Pompano Beach,Fl 33069 Toll Free 866-944-7883 Local 954-968-3766 www.944online.com
Back to top
IP Logged
 
Dave W
Experienced Member
*****
Offline


Just your basic car guy.

Posts: 5722
Location: CA
Joined: Jan 14th, 2009
Gender: Male
Re: engine stops running after starter disengages
Reply #5 - Sep 5th, 2019 at 5:53pm
Print Post  
I keep forgetting about the old cracked ignition switch module even though I've had the problem myself.
  

Dave - black 84 no longer exists. Sad 83 self destructed. All better now. Smiley
... Let's go hit some twisty roads! ...
Back to top
 
IP Logged
 
Smurf
New Member
*
Offline


944

Posts: 3
Joined: Jul 22nd, 2019
Re: engine stops running after starter disengages
Reply #6 - Sep 6th, 2019 at 12:36pm
Print Post  
Thanks, I've replaced the ignition switch module but not the key tumbler.  Not a bad idea, thanks.
  
Back to top
 
IP Logged
 
XxSteve944onlinexX
944online Admin
*****
Offline


Don't shoot the messenger.

Posts: 10388
Joined: Apr 6th, 2003
Gender: Male
Re: engine stops running after starter disengages
Reply #7 - Sep 6th, 2019 at 4:11pm
Print Post  
Remove the electrical part of the switch from the housing and use a screwdriver to turn the switch and start the car. If the problem goes away then you will know its the tumbler.
  

Steven Manfre Sales Manager 1501 nw 22nd ct  #10 Pompano Beach,Fl 33069 Toll Free 866-944-7883 Local 954-968-3766 www.944online.com
Back to top
IP Logged
 
Page Index Toggle Pages: 1
Send TopicPrint
Bookmarks: del.icio.us Digg Facebook Google Google+ Linked in reddit StumbleUpon Twitter Yahoo
 
  « Board Index ‹ Board  ^Top